Identify list of outdated 32-bit apps in iOS

Starting with iOS 10, Apple has started displaying warning message when you’re running a 32-bit app. You might encounter messages such as “The developer of this app needs to update it to improve its compatibility” or “This app will not work with future versions of iOS”.

Apple plans to phase out 32-bit apps in the App Store and has been advising developers to migrate to 64-bit. Rumour has it that the next version of iOS 11 releasing this fall will support only 64-bit apps. Apple actually requires its developers to support 64-bit when they submit new app or app update since June 2015.

Unfortunately there are still hundreds of thousand of apps in the App Store that are 32-bit only. Which means these legacy apps has not been updated by its developers since mid 2015. With iOS 10.3 update, Apple makes it easy for you to identify these apps. Go to Settings > General > About and scroll down to the Applications. If you can tap on this line, you will be taken to the “App Compatibility” page, which list all the apps that are not compatible with future iOS version. You might want to reach out to app developer for 64-bit support if you’re using any legacy app.