List of devices compatible with iOS 10 and macOS Sierra

Apple’s upcoming new iOS 10 and macOS Sierra are not compatible with a number of devices that are capable of running iOS 9 and OS X El Capitan. Specially alarming are a great number of Macs that are made obsolete by the new OS this year.

List of devices Apple is making obsolete with iOS 10 and macOS Sierra

iOS 10 will not support the following devices. This marks the end of support by Apple for A5 processor and iPhone with a 3.5 inch display.

  • iPad 1,2,3
  • iPad mini
  • iPod touch 5th generation and older
  • iPhone 4S and older

List of devices Apple is making obsolete with macOS Sierra

macOS Sierra will not run on the following Macs. The requirement is more stringent as you can run OS X El Capitan on an early 2015 MacBook or mid 2007 iMac for example. 

  • MacBook (early 2009 and older)
  • iMac (early 2009 and older)
  • MacBook Air (2009 and older)
  • MacBook Pro (2009 and older)
  • Mac mini (2009 and older)
  • Mac Pro (2009 and older)